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Windows 7 Operating System Upgrade Kit

Upgrade Kit Model Number: N8983A
Installation Note

Description of the Upgrade

This upgrade kit changes the PNA operating system from Windows XP (32-bit)
to Windows 7 (64-bit). For compatibility, some older N5242A models may
require new touchscreen hardware (not included), and many PNA-X models
may require a new CPU board assembly (included with N8983A-PC6). For more
information, refer to “Before You Install This Upgrade Kit” on page 7. The
N8983A-SP5 includes the current version of the SPAM board.

User CalSets and Cal Registers that you want to keep must be converted in
order to be read by Windows 7, as per “Step 4. Copy Any Existing Files You
Want to Keep” on page 8.

Getting Assistance from Keysight

Installing this upgrade kit requires special skills and experience. If you think
you may not be qualified to do the work, or need advice, contact Keysight.

Contacting Keysight

Assistance with test and measurements needs and information on finding a
local Keysight office are available on the Web at:
http://www.keysight.com/find/assist

If you do not have access to the Internet, please contact your Keysight field
engineer.

In any correspondence or telephone conversation, refer to the Keysight
product by its model number and full serial number. With this information,
the Keysight representative can determine whether your product is still
within its warranty period.
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Getting Prepared

Getting Prepared

The PNA contains extremely sensitive components that can be ruined if
mishandled. Follow instructions carefully when making cable connections,
especially wire harness connections.

The person performing the work accepts responsibility for the full cost of
the repair or replacement of damaged components.
To successfully install this upgrade kit, you will need the following:

— An ESD-safe work area - refer to “Protecting Your Workspace from
Electrostatic Discharge” below.

— Enough time - refer to “About Installing the Upgrade” on page 5.

If you must replace the CPU board assembly (as described in “Step 2. If
Necessary, Order a Replacement CPU Board Assembly” on page 7), you will
also need the following:

— A PDF copy or a paper copy of the PNA Service Guide - refer to
“Downloading the Online PNA Service Guide” below.

— Correct tools - refer to “Tools Required for the Installation” on page 5.

Downloading the Online PNA Service Guide

To view the online Service Guide for your PNA model number, use the following
steps:

1. Go to www.keysight.com.

2. In the Search box, enter the model number of the analyzer (Ex: N5227A)
and click Search.

Click Technical Support > Manuals.
Click Service Manual.

Click the service guide title to download the PDF file.

o a &~ w

When the PDF of the Service Guide is displayed, scroll through the
Contents section bookmarks to locate the information needed.
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Getting Prepared

Protecting Your Workspace from Electrostatic Discharge

For information, click on the Chapter 1 bookmark, “Electrostatic Discharge
Protection” in the PDF Service Guide.

ESD Equipment Required for the Installation

Description Keysight Part Number

ESD grounding wrist strap 9300-1367
5-ft grounding cord for wrist strap 9300-0980
2 x 4 ft conductive table mat and 15-ft grounding wire 9300-0797
ESD heel strap (for use with conductive floors) 9300-1308

Tools Required for the Installation

No tools are required, unless the CPU board assembly is replaced (refer to
“Step 2. If Necessary, Order a Replacement CPU Board Assembly” on page 7),
in which case the Service Guide instructions list the tools required.

About Installing the Upgrade

Products affected NB22xA, N5231/2/4/5/9A, N524xA, and N5264A

Installation to be performed by Solid State Drive (SSD) replacement
Keysight Service Center or qualified

PU Board A \ L t
personnel in ESD safe environment. ¢ oard Assembly replacemen

Installation to be performed by Touchscreen hardware replacement
Keysight Service Center only

Converting and Saving User Allow up to 30 minutes
Calibration Files and Data Files

Estimated installation time Solid State Drive replacement only: 5 minutes
CPU Board Assembly replacement: add 5 minutes

Touchscreen hardware replacement: add 2 hours

Estimated post-installation 5 minutes
procedures time SPAM board replacement: add 1 to 2 hours

1. See “Downloading the Online PNA Service Guide” on page 4.
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ltems Included in the Upgrade Kit

Items Included in the Upgrade Kit

Check the contents of your kit against the following list. If any part is missing or
damaged, contact Keysight Technologies. Refer to “Getting Assistance from
Keysight” on page 3.

Table 1 Contents of Upgrade Kit N8983A

Description Qty Part Number
Installation note (this document) 1 N8983-90001
Solid state drive (SSD) for 2.0 GHz i7 CPU 1 N5242-60132
Windows 7 Certificate of Authenticity label 1 N/A
(installed on SSD chassis next to thumbscrew)
Option PC6:
CPU board assembly, Intel ® 2.0 GHz Core ® i/ 1 W1312-60196
Option SP5:
Signal Processing ADC Module (SPAM) board 5 (shield tabs removed) 1 N5240-60078
IF multiplexer board P603 to A16 SPAM board J2 1 N5247-60023
IF multiplexer board P203 to A16 SPAM board J5 1 Nb5247-60024
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Before You Install This Upgrade Kit

Before You Install This Upgrade Kit

Step 1. If Necessary, Replace the Touchscreen Hardware for Early
N5242A Models

If your N5242A PNA has a numeric serial number prefix below MY4822,
SG4822, and US4812, and still has the original touchscreen, it will no longer
be possible to calibrate the touchscreen after the upgrade. If this is a concern,
return your PNA to Keysight to have the touchscreen and associated parts
replaced.

Before returning your PNA to Keysight, complete steps 2. 3, and 4

If accurate touchscreen operation is not a concern, keep your existing
touchscreen, but make sure you calibrate it one last time before installing this
upgrade kit.

Step 2. If Necessary, Order a Replacement CPU Board Assembly

If you purchased N8983A-PC6 or have an N522xA or N5231/2/4/5/9A PNA
model, you do NOT need to order a new CPU board assembly. Proceed to Step
3.

For N524xA and N5264A models, only CPU part number W1312-60196 is
compatible with this upgrade kit. This is included with N8983A-PC6.

If you have an N524xA, or N5264A PNA model, you must verify that your CPU
board assembly part number is W1312-60196. On the rear panel of the PNA,
locate the assembly containing the LAN and USB ports - this is the CPU

assembly. A label! below the USB ports contains the CPU board assembly part
number. If you have a different part number, and you did not order
N8983A-PC6, contact Keysight to order part number W1312-60196.

If you choose to have Keysight Service Center personnel replace your CPU
board assembly, instruct them NOT to install an SSD in the assembly. You
will install the SSD shipped with this upgrade kit in your new CPU board
assembly.

1. If the label is missing, you can learn your System CPU version using the PNA software.
On the PNA front panel, press Help > About Network Analyzer. In the window displayed,
find “System CPU Version.” If the value is below 6.0, you must replace your CPU board
assembly. Contact Keysight to order part number W1312-60196.
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Step 3.

Before You Install This Upgrade Kit

If Necessary, Download PNA Firmware for Your Existing

Windows XP Drive

Step 4.

Before you install this upgrade kit, it is strongly recommended that you have
firmware revision A.09.90.05 (or later, but within the A.09.90.xx range) installed
in your PNA. If already installed, proceed to Step 4.

Windows XP and the Windows 7 drives require the PNA internal flash memory
to have different formats. PNA firmware revision A.09.90.08 (or later, but within
the A.09.90.xx range) and Windows 7 can recognize both formats and act
accordingly.

If older PNA firmware is installed and the old Windows XP drive is reused after
this upgrade kit is installed, the PNA will not function, errors will be generated,
and the current contents of the flash memory will be corrupted, making any
recovery extremely difficult.

To learn which firmware revision is currently loaded in your PNA, press Help >
About Network Analyzer. In the window displayed, find “Application Code
Version.”

Download firmware at no charge at:
http://na.support.keysight.com/pna/firmware.

Copy Any Existing Files You Want to Keep

Upgrading to Windows 7 will not affect the PNA calibration or any installed
permanent options, however all temporary options will be lost. If the loss of
temporary options is an issue, then print or copy the text file gen.lic to some
other media so that the keywords can later be reinstalled on the Windows 7
drive. This file is located in C:\Program Files\Keysight\Network Analyzer. You
may also want to copy other existing files from your XP drive to some other
media before you install the Windows 7 drive. The following table lists the
locations where these files can be found on the XP drive and where they should
be located on the Windows 7 drive.

User CalSets and Cal Registers cannot be copied to the new drive. Any
User CalSets and Cal Registers you want to keep must be converted to
“.cal” or “.csa” files. To do this, each one must be recalled using File >
Recall and stored as a “.cal” or “.csa” file using File > Save As. For more
information, read “Save and Recall a File” in PNA Help.
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Table 1

File Type

Before You Install This Upgrade Kit

Location on Windows XP
Drive

Files to Copy Before Installing the Windows 7 Drive

Location on Windows 7
Drive

State Files (.csa,  C:\Program C:\Users\Public\Document ~ Copy from XP location to

.cst, .sta, .cal) Files\Keysight\Network s\Network Analyzer Win7 location
Analyzer\Documents

Result Files C:\Program C:\Users\Public\Document  Copy from XP location to

(.snp, .csv, .cti)

Files\Keysight\Network
Analyzer\Documents

s\Network Analyzer

Win7 location

Mixer Files
(.mxr, mxrx)

C:\Program
Files\Keysight\Network
Analyzer\Mixer

C:\Users\Public\Document
s\Network Analyzer\Mixer

Copy from XP location to
Win7 location

Device Driver
Files for DC or
Generic Sources

C:\Program
Files\Keysight\Network
Analyzer\Drivers

C:\Users\Public\Document
s\Network Analyzer\Drivers

Copy from XP location to
Win7 location

Disk Based ECal
User
Characterizatio
n Files (.euc)

C:\Program
Files\Keysight\Network
Analyzer\ECal User
Characterizations

C:A\Users\Public\Document
s\Network Analyzer\ECal
User Characterizations

Copy from XP location to
Win7 location

Noise ENR Files
(.enr)

C:\Program
Files\Keysight\Network
Analyzer\Documents\Nois
e

C:\Users\Public\Document
s\Network Analyzer\Noise

Copy from XP location to
Win7 location

User Cal Kits
(.wks)

C:\Program
Files\Keysight\Network
Analyzer\PnaCalKits\User\
userkits_7.50.wks

Hidden Folder

In the Win7 PNA, use the
“Open..."button at the top
of the Edit Cal Kits dialog
to browse to the “.wks”
file you copied from your
Windows XP drive. Select
the “*.wks” file type filter
in the drop-down menu.
Select your “.wks” file to
load all your cal kits.

Color Scheme

C:\Program
Files\Keysight\Network
Analyzer\Documents\Colo
rs

C:\Users\Public\Document
s\Network Analyzer\Colors

Copy from XP location to
Win7 location
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Upgrade Procedure

Upgrade Procedure

The network analyzer must be in proper working condition prior to
installing this option. Any necessary repairs must be made before
proceeding with this installation.

1. Confirm that you have the correct touchscreen display installed - for
information, refer to “Step 1. If Necessary, Replace the Touchscreen
Hardware for Early N5242A Models” on page 7.

2. Confirm that you have the correct CPU board assembly installed in your
PNA, or that you have received a new CPU board assembly, either in the
N8983A-PC6, or shipped from Keysight Support Parts Organization (SPO).
If you must replace the CPU board assembly, follow the instructions in
“Removing and Replacing the CPU Board Assembly,” located in chapter 7
of the Service Guide.

3. If you purchased N8983A-SP5:

a. Install the new SPAM board. Refer to the instructions located in
chapter 7 of the Service Guide.

b. If your PNA is a 2-port model, replace two flex cables with those
included in the kit. See the cable descriptions in “Items Included in
the Upgrade Kit” on page 6 of this document. For a graphic showing
cable locations, refer to the chapter 6 of the Service Guide.

4. Replace the Windows XP drive with the new Windows 7 drive included in
this upgrade kit using the following instructions. If you have not done this
before, or you want to see a graphic, refer to “Removing and Replacing the
Hard Disk Drive (HDD),” located in chapter 7 of the Service Guide.

a. Power off the PNA.

b. Remove all USB devices except the mouse and keyboard from the
PNA.

c. Remove the power cord from the PNA.

d. Loosen the thumbscrew on the installed SSD and remove the SSD
from the drive bay of the CPU board assembly.

e. Insert the new, supplied SSD into the drive bay of the CPU board
assembly and hand tighten the thumbscrew on the SSD.

f. Reinsert the power cord to the PNA.

g. Verify that there are no USB devices connected to the PNA except a
mouse and keyboard.

h. Power on the PNA.

5. The PNA will go through its initialization process. This will take about 10
minutes and may involve as many as five reboots. Do not proceed until all
activity has stopped.
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Upgrade Procedure

6. The touchscreen will likely be uncalibrated and reversed left-to-right -
this is normal. Calibrate the touchscreen by pressing System >
Touchscreen > Calibrate Touchscreen. Follow the instructions displayed.

7. If desired, copy any files you saved earlier to their new locations on the
Windows 7 drive - see Table 1 on page 9.

8. Set aside the old Windows XP drive (and CPU board assembly, if replaced)
in case you later discover you need a file from the old drive.

If, after you install the Windows 7 drive, you need to access some files on
the old XP drive, use a USB 2.5-inch hard drive enclosure. These are
inexpensive and are very simple to use. Just make sure you get an
enclosure that matches your existing hard drive interface - either SATA
(slide-in drive) or PATA (internal drive).

9. The PNA does not come with any antivirus software installed. You may
want to install an antivirus program before connecting the PNA to the
Internet. You may also want to download and install any recent Windows
Updates.

10.This upgrade kit contains PNA firmware revision A.10.00.xx. You may want
to verify that this is the most recent firmware revision available for
Windows 7 at: http://na.support.keysight.com/pna/firmware.

11.The upgrade is now completed, and the PNA is ready for use.

You may notice that the Windows User Access Control (UAC) will prompt
you for permission to install programs or make other critical changes.
While this feature can be turned off, this is not recommended due to
security concerns

Firmware for Windows 7 will always be A.10.00.00 or higher. Firmware for
Windows XP will always be below A.09.99.99. You cannot run firmware
below A.10.00.00 on a Windows 7 PNA. Likewise, you cannot run firmware
A.10.00.00 or above on a Windows XP PNA.

For many years now, the administrator user name has been “pna-admin”
and the password has been “keysight”. In Windows 7, the user name will
remain the same, but the password has changed. All PNAs with Windows 7
will use the default lower-case password of “pna”. If the short length
violates your company policy, it can be lengthened.

The Windows Properties dialog box (to access, right-click Computer, then
click Properties) does not indicate Windows 7. Instead, it shows “Windows
Embedded Standard.” This is Windows 7 made specifically for embedded
systems such as the PNA.
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Upgrade Procedure

The network analyzer must be in proper working condition prior to
installing this option. Any necessary repairs must be made before
proceeding with this installation.
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